blob: 07b8abbf203e01a20d209a6360316ee663c3c7cd [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001SUMMARY = "DS-5 Streamline Gator daemon"
2DESCRIPTION = "Target-side daemon gathering data for ARM Streamline \
3 Performance Analyzer."
4HOMEPAGE = "https://github.com/ARM-software/gator"
5
6# Note that Gator uses the Linux Perf API for
7# most of its data collection. Check that your Kernel follow the
8# configuration requirement specified here:
9# https://github.com/ARM-software/gator#kernel-configuration
10
11LICENSE = "GPL-2.0-only & LGPL-2.1-or-later & Apache-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://libsensors/COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
14 file://mxml/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
15 file://k/perf_event.h;endline=14;md5=e548bf30a60b2ed11ef2dcf7bfdac230 \
16 "
17
18SRCREV = "9d8d75fa08352470c51abc23fe3b314879bd8b78"
19SRC_URI = "git://github.com/ARM-software/gator.git;protocol=http;branch=main;protocol=https \
20 file://0001-Sources.mk-Remove-xml-PmuXMLParser.h-header-from-GAT.patch;striplevel=2 \
Patrick Williams92b42cb2022-09-03 06:53:57 -050021 file://0001-daemon-mxml-Define-_GNU_SOURCE.patch;striplevel=2 \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040022 "
23
24S = "${WORKDIR}/git/daemon"
25
26COMPATIBLE_HOST = "aarch64.*-linux"
27
28EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\"${sysconfdir}\"' \
29 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
30 'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti' CC='${CC}' CXX='${CXX}' V=1"
31
32do_install() {
33 install -d ${D}${sbindir}
34 install -m 0755 ${S}/gatord ${D}${sbindir}/gatord
35}