blob: 9e997de1d3bbf1a634fc9aa818de7c3e89216b59 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A Linux kernel module providing user space access to Trusted Services"
2DESCRIPTION = "${SUMMARY}"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=05e355bbd617507216a836c56cf24983"
5
6inherit module
7
8SRC_URI = "git://gitlab.arm.com/linux-arm/linux-trusted-services;protocol=https;branch=main \
9 file://Makefile;subdir=git \
10 "
11S = "${WORKDIR}/git"
12
13# Tag tee-v1.1
14SRCREV = "3b543b7591505b715f332c972248a3ea41604d83"
15
16COMPATIBLE_HOST = "(arm|aarch64).*-linux"
17KERNEL_MODULE_AUTOLOAD += "arm-ffa-tee"
18
19do_install:append() {
20 install -d ${D}${includedir}
21 install -m 0644 ${S}/uapi/arm_ffa_tee.h ${D}${includedir}/
22}