blob: 8d86197d3db855ef5fc796c4610898b49c3744e0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "FF-A Debugfs Linux kernel module"
2DESCRIPTION = "This out-of-tree kernel module exposes FF-A operations to user space \
3used for development purposes"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=05e355bbd617507216a836c56cf24983"
6
7inherit module
8
9SRC_URI = "git://gitlab.arm.com/linux-arm/linux-trusted-services;protocol=https;branch=debugfs \
10 file://Makefile;subdir=git \
11 "
12S = "${WORKDIR}/git"
13
14# Tag 5.0.0.
15SRCREV = "6ec4196a59db8204ed670ef3b78f24a8234b85a6"
16
17COMPATIBLE_HOST = "(arm|aarch64).*-linux"
18KERNEL_MODULE_AUTOLOAD += "arm-ffa-user"
19KERNEL_MODULE_PROBECONF += "arm-ffa-user"
20
21# This debugfs driver is used only by uefi-test for testing SmmGW SP
22# UUIDs = SMM Gateway SP
23FFA-USER-UUID-LIST ?= "ed32d533-99e6-4209-9cc0-2d72cdd998a7"
24module_conf_arm-ffa-user = "options arm-ffa-user uuid_str_list=${FFA-USER-UUID-LIST}"
25
26do_install:append() {
27 install -d ${D}${includedir}
28 install -m 0644 ${S}/arm_ffa_user.h ${D}${includedir}/
29}