blob: 0982df3d686d7aea2cb50c9167fe32e59843c183 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001FILESEXTRAPATHS:prepend := "${THISDIR}/optee-os:"
2require optee-os_3.18.0.bb
3
4SUMMARY = "OP-TEE Trusted OS TA devkit"
5DESCRIPTION = "OP-TEE TA devkit for build TAs"
6HOMEPAGE = "https://www.op-tee.org/"
7
8DEPENDS += "python3-pycryptodome-native"
9
10do_install() {
11 #install TA devkit
12 install -d ${D}${includedir}/optee/export-user_ta/
13 for f in ${B}/export-ta_${OPTEE_ARCH}/* ; do
14 cp -aR $f ${D}${includedir}/optee/export-user_ta/
15 done
16}
17
18do_deploy() {
19 echo "Do not inherit do_deploy from optee-os."
20}
21
22FILES:${PN} = "${includedir}/optee/"
23
24# Build paths are currently embedded
25INSANE_SKIP:${PN}-dev += "buildpaths"