blob: 5be436b64939ccc250c672485219fbe1ede58264 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Trusted Services uefi-test deployment for arm-linux. \
2 Used for running service level tests from Linux user-space \
3 on an Arm platform with real deployments of UEFI SMM services."
4
5TS_ENV = "arm-linux"
6
7require trusted-services.inc
8
9DEPENDS += "libts python3-protobuf-native"
10RDEPENDS:${PN} += "libts arm-ffa-user"
11
12OECMAKE_SOURCEPATH = "${S}/deployments/uefi-test/${TS_ENV}"
13
14FILES:${PN} = "${bindir}/uefi-test"
15
16do_install:append () {
17 install -d ${D}${bindir}
18 mv ${D}${TS_INSTALL}/bin/uefi-test ${D}${bindir}
19
20 rm -r --one-file-system ${D}${TS_INSTALL}
21}