blob: ba8b1a24e0385c187af5b815a6141f70778af83d [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "File system QA test suite"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038"
4
5SRCREV_FORMAT = "xfstests_unionmount"
6
7SRC_URI = "\
8 git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \
9 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
10 file://0001-Add-a-return-type-to-aio_rw.patch \
11 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
12"
13
14SRCREV_xfstests = "16ddbd1aee295f64695916cf3621aef57f1163ba"
15SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
16
17S = "${WORKDIR}/git"
18
19inherit autotools-brokensep useradd
20
21DEPENDS += "xfsprogs acl"
22RDEPENDS:${PN} += "\
23 bash \
24 bc \
25 coreutils \
26 e2fsprogs \
27 e2fsprogs-tune2fs \
28 e2fsprogs-resize2fs \
29 libaio \
30 libcap-bin \
31 overlayfs-progs \
32 perl \
33 python3 \
34 python3-core \
35 xfsprogs \
36 acl \
37"
38
39USERADD_PACKAGES = "${PN}"
40# these users are necessary to run the tests
41USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
42
43EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
44
45# install-sh script in the project is outdated
46# we use the one from the latest libtool to solve installation issues
47# It looks like the upstream is not interested in having it fixed :(
48# https://www.spinics.net/lists/fstests/msg16981.html
49do_configure:prepend() {
50 cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B}
51}
52
53do_install:append() {
54 unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
55 install -d ${D}/usr/xfstests/unionmount-testsuite/tests
56 install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
57 install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir
58 install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir
59 install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir
60}
61
62FILES:${PN} += "\
63 /usr/xfstests \
64"