blob: cf73f823c820de3b227a6d59ebf72c000a233dfe [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
5 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
6"
7
8SECTION = "x11/gnome"
9
10DEPENDS = " \
11 udev \
12 libnotify \
13 libcanberra \
14 bluez5 \
15 upower \
16 gtk4 \
17 gsound \
18 libadwaita \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22GTKDOC_MESON_OPTION = "gtk_doc"
23GTKIC_VERSION = "4"
24
25inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection
26
27REQUIRED_DISTRO_FEATURES = "x11"
28
29SRC_URI[archive.sha256sum] = "c37a2a07f77d4816b261e6c2086a056ed9767c3881dfabc826f4f82f6e1aa302"
30
31BT_PULSE_PACKS = " \
32 pulseaudio-lib-bluez5-util \
33 pulseaudio-module-bluetooth-discover \
34 pulseaudio-module-bluetooth-policy \
35 pulseaudio-module-bluez5-device \
36 pulseaudio-module-bluez5-discover \
37"
38
39PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
40PACKAGECONFIG[pulseaudio] = ",,,${BT_PULSE_PACKS}"
41
42FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"
43
44RDEPENDS:${PN} += "bluez5"