blob: c78bbae7b8706ff631946fac7c817a0dce6e5686 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3SECTION = "otherosfs"
4LICENSE = "GPL-3.0-only & LGPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7SRCREV = "316522036133d44ed02cd39ed2748e2b59c85b30"
8SRC_URI = "git://git.samba.org/cifs-utils.git;branch=master"
9
10S = "${WORKDIR}/git"
11DEPENDS += "libtalloc"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
15# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install:append is needed
16PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
17# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install:append is needed
18PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
19PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
20PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
21PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
22
23inherit autotools pkgconfig
24
25do_configure:prepend() {
26 # want installed to /usr/sbin rather than /sbin to be DISTRO_FEATURES usrmerge compliant
27 # must override ROOTSBINDIR (default '/sbin'),
28 # setting --exec-prefix or --prefix in EXTRA_OECONF does not work
29 if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
30 export ROOTSBINDIR=${sbindir}
31 fi
32}
33
34do_install:append() {
35 if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','false','true',d)}; then
36 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
37 # is installed to /sbin
38 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
39 fi
40}
41
42FILES:${PN} += "${base_libdir}/security"
43FILES:${PN}-dbg += "${base_libdir}/security/.debug"
44RRECOMMENDS:${PN} = "kernel-module-cifs"