blob: a4389ce7e8385cf06a52f16c14e7c018a92beaef [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "HTTP based time synchronization tool"
2DESCRIPTION = "The HTTP Time Protocol (HTP) is used to synchronize a computer's time with\
3 web servers as reference time source. This program can be used instead\
4 ntpdate or similar, in networks that has a firewall blocking the NTP port.\
5 Htpdate will synchronize the computer time to Greenwich Mean Time (GMT),\
6 using the timestamps from HTTP headers found in web servers response (the\
7 HEAD method will be used to get the information).\
8 Htpdate works through proxy servers. Accuracy of htpdate will be usually\
9 within 0.5 seconds (better with multiple servers).\
10"
11HOMEPAGE = "https://github.com/twekkel/htpdate"
12BUGTRACKER = "https://github.com/twekkel/htpdate/issues"
13LICENSE = "GPL-2.0-or-later"
14LIC_FILES_CHKSUM = "file://htpdate.c;beginline=26;endline=30;md5=2b6cdb94bd5349646d7e33f9f501eef7"
15
16SRC_URI = "http://www.vervest.org/htp/archive/c/htpdate-${PV}.tar.gz"
17SRC_URI[sha256sum] = "3cdc558ec8e53ef374a42490b2f28c0b23981fa8754a6d7182044707828ad1e9"
18
19TARGET_CC_ARCH += "${LDFLAGS}"
20
21do_configure () {
22 :
23}
24
25do_compile () {
26 oe_runmake
27}
28
29do_install () {
30 oe_runmake install 'INSTALL=install' 'STRIP=echo' 'DESTDIR=${D}'
31}