blob: 71ffb7ba448393bc2045a0662fa0e1f32dc150c6 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
2Linux operating system."
3SUMMARY = "strongSwan is an OpenSource IPsec implementation"
4HOMEPAGE = "http://www.strongswan.org"
5SECTION = "net"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8DEPENDS = "flex-native flex bison-native"
9DEPENDS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', ' tpm2-tss', '', d)}"
10
11SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
12 "
13
14SRC_URI[sha256sum] = "9e64a2ba62efeac81abff1d962522404ebc6ed6c0d352a23ab7c0b2c639e3fcf"
15
16UPSTREAM_CHECK_REGEX = "strongswan-(?P<pver>\d+(\.\d+)+)\.tar"
17
18EXTRA_OECONF = " \
19 --without-lib-prefix \
20 --with-dev-headers=${includedir}/strongswan \
21"
22
23EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
24
25PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl curve25519\
26 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-charon', 'charon', d)} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', 'tpm2', '', d)} \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'ima', 'tnc-imc imc-hcd imc-os imc-scanner imc-attestation', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'ima', 'tnc-imv imv-hcd imv-os imv-scanner imv-attestation', '', d)} \
30"
31
32PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni"
33PACKAGECONFIG[bfd] = "--enable-bfd-backtraces,--disable-bfd-backtraces,binutils"
34PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"
35PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,${PN}-plugin-curl"
36PACKAGECONFIG[eap-identity] = "--enable-eap-identity,--disable-eap-identity,,${PN}-plugin-eap-identity"
37PACKAGECONFIG[eap-mschapv2] = "--enable-eap-mschapv2,--disable-eap-mschapv2,,${PN}-plugin-eap-mschapv2"
38PACKAGECONFIG[gmp] = "--enable-gmp,--disable-gmp,gmp,${PN}-plugin-gmp"
39PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap,${PN}-plugin-ldap"
40PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,${PN}-plugin-mysql"
41PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl,${PN}-plugin-openssl"
42PACKAGECONFIG[scep] = "--enable-scepclient,--disable-scepclient,"
43PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,${PN}-plugin-soup"
44PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3,${PN}-plugin-sqlite"
45PACKAGECONFIG[stroke] = "--enable-stroke,--disable-stroke,,${PN}-plugin-stroke"
46PACKAGECONFIG[swanctl] = "--enable-swanctl,--disable-swanctl,,libgcc"
47PACKAGECONFIG[curve25519] = "--enable-curve25519,--disable-curve25519,, ${PN}-plugin-curve25519"
48
49# requires swanctl
50PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
51
52# tpm needs meta-tpm layer
53PACKAGECONFIG[tpm2] = "--enable-tpm,--disable-tpm,,${PN}-plugin-tpm"
54
55
56# integraty configuration needs meta-integraty
57#imc
58PACKAGECONFIG[tnc-imc] = "--enable-tnc-imc,--disable-tnc-imc,, ${PN}-plugin-tnc-imc ${PN}-plugin-tnc-tnccs"
59PACKAGECONFIG[imc-test] = "--enable-imc-test,--disable-imc-test,,"
60PACKAGECONFIG[imc-scanner] = "--enable-imc-scanner,--disable-imc-scanner,,"
61PACKAGECONFIG[imc-os] = "--enable-imc-os,--disable-imc-os,,"
62PACKAGECONFIG[imc-attestation] = "--enable-imc-attestation,--disable-imc-attestation,,"
63PACKAGECONFIG[imc-swima] = "--enable-imc-swima, --disable-imc-swima, json-c,"
64PACKAGECONFIG[imc-hcd] = "--enable-imc-hcd, --disable-imc-hcd,,"
65
66#imv set
67PACKAGECONFIG[tnc-imv] = "--enable-tnc-imv,--disable-tnc-imv,, ${PN}-plugin-tnc-imv ${PN}-plugin-tnc-tnccs"
68PACKAGECONFIG[imv-test] = "--enable-imv-test,--disable-imv-test,,"
69PACKAGECONFIG[imv-scanner] = "--enable-imv-scanner,--disable-imv-scanner,,"
70PACKAGECONFIG[imv-os] = "--enable-imv-os,--disable-imv-os,,"
71PACKAGECONFIG[imv-attestation] = "--enable-imv-attestation,--disable-imv-attestation,,"
72PACKAGECONFIG[imv-swima] = "--enable-imv-swima, --disable-imv-swima, json-c,"
73PACKAGECONFIG[imv-hcd] = "--enable-imv-hcd, --disable-imv-hcd,,"
74
75PACKAGECONFIG[tnc-ifmap] = "--enable-tnc-ifmap,--disable-tnc-ifmap, libxml2, ${PN}-plugin-tnc-ifmap"
76PACKAGECONFIG[tnc-pdp] = "--enable-tnc-pdp,--disable-tnc-pdp,, ${PN}-plugin-tnc-pdp"
77
78PACKAGECONFIG[tnccs-11] = "--enable-tnccs-11,--disable-tnccs-11,libxml2, ${PN}-plugin-tnccs-11"
79PACKAGECONFIG[tnccs-20] = "--enable-tnccs-20,--disable-tnccs-20,, ${PN}-plugin-tnccs-20"
80PACKAGECONFIG[tnccs-dynamic] = "--enable-tnccs-dynamic,--disable-tnccs-dynamic,,${PN}-plugin-tnccs-dynamic"
81
82inherit autotools systemd pkgconfig
83
84RRECOMMENDS:${PN} = "kernel-module-ah4 \
85 kernel-module-esp4 \
86 kernel-module-xfrm-user \
87 "
88
89FILES:${PN} += "${libdir}/ipsec/lib*${SOLIBS}"
90FILES:${PN}-dbg += "${bindir}/.debug ${sbindir}/.debug ${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"
91FILES:${PN}-dev += "${libdir}/ipsec/lib*${SOLIBSDEV} ${libdir}/ipsec/*.la ${libdir}/ipsec/include/config.h"
92FILES:${PN}-staticdev += "${libdir}/ipsec/*.a"
93
94CONFFILES:${PN} = "${sysconfdir}/*.conf ${sysconfdir}/ipsec.d/*.conf ${sysconfdir}/strongswan.d/*.conf"
95
96PACKAGES += "${PN}-plugins"
97ALLOW_EMPTY:${PN}-plugins = "1"
98
99PACKAGE_BEFORE_PN = "${PN}-imcvs ${PN}-imcvs-dbg"
100ALLOW_EMPTY:${PN}-imcvs = "1"
101
102FILES:${PN}-imcvs = "${libdir}/ipsec/imcvs/*.so"
103FILES:${PN}-imcvs-dbg += "${libdir}/ipsec/imcvs/.debug"
104
105PACKAGES_DYNAMIC += "^${PN}-plugin-.*$"
106NOAUTOPACKAGEDEBUG = "1"
107
108python split_strongswan_plugins () {
109 sysconfdir = d.expand('${sysconfdir}/strongswan.d/charon')
110 libdir = d.expand('${libdir}/ipsec/plugins')
111 dbglibdir = os.path.join(libdir, '.debug')
112
113 def add_plugin_conf(f, pkg, file_regex, output_pattern, modulename):
114 dvar = d.getVar('PKGD')
115 oldfiles = d.getVar('CONFFILES:' + pkg)
116 newfile = '/' + os.path.relpath(f, dvar)
117
118 if not oldfiles:
119 d.setVar('CONFFILES:' + pkg, newfile)
120 else:
121 d.setVar('CONFFILES:' + pkg, oldfiles + " " + newfile)
122
123 split_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.so', '${PN}-plugin-%s', 'strongSwan %s plugin', prepend=True)
124 do_split_packages(d, sysconfdir, r'(.*)\.conf', '${PN}-plugin-%s', 'strongSwan %s plugin', prepend=True, hook=add_plugin_conf)
125
126 split_dbg_packages = do_split_packages(d, dbglibdir, r'libstrongswan-(.*)\.so', '${PN}-plugin-%s-dbg', 'strongSwan %s plugin - Debugging files', prepend=True, extra_depends='${PN}-dbg')
127 split_dev_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.la', '${PN}-plugin-%s-dev', 'strongSwan %s plugin - Development files', prepend=True, extra_depends='${PN}-dev')
128 split_staticdev_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.a', '${PN}-plugin-%s-staticdev', 'strongSwan %s plugin - Development files (Static Libraries)', prepend=True, extra_depends='${PN}-staticdev')
129
130 if split_packages:
131 pn = d.getVar('PN')
132 d.setVar('RRECOMMENDS:' + pn + '-plugins', ' '.join(split_packages))
133 d.appendVar('RRECOMMENDS:' + pn + '-dbg', ' ' + ' '.join(split_dbg_packages))
134 d.appendVar('RRECOMMENDS:' + pn + '-dev', ' ' + ' '.join(split_dev_packages))
135 d.appendVar('RRECOMMENDS:' + pn + '-staticdev', ' ' + ' '.join(split_staticdev_packages))
136}
137
138PACKAGESPLITFUNCS:prepend = "split_strongswan_plugins "
139
140# Install some default plugins based on default strongSwan ./configure options
141# See https://wiki.strongswan.org/projects/strongswan/wiki/Pluginlist
142RDEPENDS:${PN} += "\
143 ${PN}-plugin-aes \
144 ${PN}-plugin-attr \
145 ${PN}-plugin-cmac \
146 ${PN}-plugin-constraints \
147 ${PN}-plugin-des \
148 ${PN}-plugin-dnskey \
149 ${PN}-plugin-drbg \
150 ${PN}-plugin-fips-prf \
151 ${PN}-plugin-hmac \
152 ${PN}-plugin-kdf \
153 ${PN}-plugin-kernel-netlink \
154 ${PN}-plugin-md5 \
155 ${PN}-plugin-mgf1 \
156 ${PN}-plugin-nonce \
157 ${PN}-plugin-pem \
158 ${PN}-plugin-pgp \
159 ${PN}-plugin-pkcs1 \
160 ${PN}-plugin-pkcs7 \
161 ${PN}-plugin-pkcs8 \
162 ${PN}-plugin-pkcs12 \
163 ${PN}-plugin-pubkey \
164 ${PN}-plugin-random \
165 ${PN}-plugin-rc2 \
166 ${PN}-plugin-resolve \
167 ${PN}-plugin-revocation \
168 ${PN}-plugin-sha1 \
169 ${PN}-plugin-sha2 \
170 ${PN}-plugin-socket-default \
171 ${PN}-plugin-sshkey \
172 ${PN}-plugin-updown \
173 ${PN}-plugin-vici \
174 ${PN}-plugin-x509 \
175 ${PN}-plugin-xauth-generic \
176 ${PN}-plugin-xcbc \
177 "
178
179RPROVIDES:${PN} += "${PN}-systemd"
180RREPLACES:${PN} += "${PN}-systemd"
181RCONFLICTS:${PN} += "${PN}-systemd"
182
183# The deprecated legacy 'strongswan-starter' service should only be used when charon and
184# stroke are enabled. When swanctl is in use, 'strongswan.service' is needed.
185# See: https://wiki.strongswan.org/projects/strongswan/wiki/Charon-systemd
186SYSTEMD_SERVICE:${PN} = " \
187 ${@bb.utils.contains('PACKAGECONFIG', 'swanctl', '${BPN}.service', '', d)} \
188 ${@bb.utils.contains('PACKAGECONFIG', 'charon', '${BPN}-starter.service', '', d)} \
189"