blob: d809a564e9237cdc77e8a7175758bbc2139f9718 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Dhrystone CPU benchmark"
2LICENSE = "PD"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
4
5SRC_URI = "http://www.netlib.org/benchmark/dhry-c;downloadfilename=dhry-c.shar \
6 file://dhrystone.patch"
7SRC_URI[md5sum] = "75aa5909c174eed98c134be2f56307da"
8SRC_URI[sha256sum] = "038a7e9169787125c3451a6c941f3aca5db2d2f3863871afcdce154ef17f4e3e"
9
10# Need to override Makefile variables
11EXTRA_OEMAKE = "-e MAKEFLAGS="
12
13do_unpack() {
14 [ -d ${S} ] || mkdir -p ${S}
15 cd ${S}
16 sh ${DL_DIR}/dhry-c.shar
17}
18do_install() {
19 install -d ${D}${bindir}
20 install -m 0755 ${S}/dhry ${D}${bindir}
21}
22
23# Prevent procedure merging as required by dhrystone.c:
24CFLAGS += "-fno-lto"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025CFLAGS:append:toolchain-clang = " -Wno-error=implicit-function-declaration -Wno-error=deprecated-non-prototype -Wno-error=implicit-int"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026
27LDFLAGS += "-fno-lto"