blob: 5e0a488429a54023d8414cec546923ed7450f731 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Install a Debian system into a subdirectory"
2HOMEPAGE = "https://wiki.debian.org/Debootstrap"
3SECTION = "devel"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
6
7SRC_URI = "\
8 http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_${PV}.tar.gz \
9 file://0001-support-to-override-usr-sbin-and-usr-share.patch \
10 file://0002-support-to-override-usr-bin-arch-test.patch \
11 file://0001-do-not-hardcode-the-full-path-of-dpkg.patch \
12"
13
14SRC_URI[sha256sum] = "45887cf0582e6d16598e50713278d16b2272d02bdd117a9876e98277300dabd4"
15
16S = "${WORKDIR}/debootstrap"
17
18DEPENDS = " \
19 virtual/fakeroot-native \
20"
21
22fakeroot do_install() {
23 oe_runmake 'DESTDIR=${D}' install
24 chown -R root:root ${D}${datadir}/debootstrap
25}
26
27BBCLASSEXTEND = "native nativesdk"