blob: e0dfc3dae3b4aa267223ae59a5f826bbe108cec4 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script."
2DESCRIPTION = "\
3 makeself.sh is a small shell script that generates a self-extractable \
4 compressed tar archive from a directory. The resulting file appears as \
5 a shell script (many of those have a .run suffix), and can be launched as is.\
6"
7HOMEPAGE = "https://makeself.io/"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "\
12 git://git@github.com/megastep/makeself.git;protocol=https;branch=master \
13"
14
15SRCREV = "5742be6410bfad2c619fb1e98bf795e8fa0913c7"
16
17S = "${WORKDIR}/git"
18
19do_configure[noexec] = "1"
20do_compile[noexec] = "1"
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 ${S}/makeself.1 ${D}${bindir}/
25 install -m 0755 ${S}/makeself.sh ${D}${bindir}/
26 install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/
27}
28
29BBCLASSEXTEND = "native"