blob: 502262820a4746ffd930dee350dcba176410edbb [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "JSON for modern C++"
2HOMEPAGE = "https://nlohmann.github.io/json/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588"
6
7CVE_PRODUCT = "json-for-modern-cpp"
8
9SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1;protocol=https \
10 "
11
12SRCREV = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
19
20# nlohmann-json is a header only C++ library, so the main package will be empty.
21
22RDEPENDS:${PN}-dev = ""
23
24BBCLASSEXTEND = "native nativesdk"
25
26# other packages commonly reference the file directly as "json.hpp"
27# create symlink to allow this usage
28do_install:append() {
29 ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
30}