blob: b75802f09fcbf51b9fd5d4e68da10bda69731ec9 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Zlog is a pure C logging library"
2HOMEPAGE = "https://github.com/HardySimpson/zlog"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRCREV = "dc2c284664757fce6ef8f96f8b3ab667a53ef489"
7SRC_URI = "git://github.com/HardySimpson/zlog;branch=master;protocol=https"
8
9S = "${WORKDIR}/git"
10
11inherit pkgconfig
12
13EXTRA_OEMAKE = "CC='${CC}' LD='${LD}' LIBRARY_PATH=${baselib}"
14
15do_install() {
16 oe_runmake install PREFIX=${D}${exec_prefix} INSTALL=install
17}