blob: 010288b0d646958bd6b91d1b111c82681c97bba5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "ImageMagick is an image conversion toolkit"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002SECTION = "console/utils"
Brad Bishop19323692019-04-05 15:28:33 -04003HOMEPAGE = "https://www.imagemagick.org/"
4DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \
5editing raster and vector image files. It can read and write over 200 image file formats."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006LICENSE = "ImageMagick"
Andrew Geissler615f2f12022-07-15 14:00:58 -05007LIC_FILES_CHKSUM = "file://LICENSE;md5=b97c12a9213df1499565d69b92c73dd7 \
8 file://NOTICE;md5=d8b9d2ccf273687ad12ebd06e5d8478f"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
Brad Bishop34ae6002019-04-08 15:21:03 -040010DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011
12BASE_PV := "${PV}"
Andrew Geissler615f2f12022-07-15 14:00:58 -050013PV .= "-62"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014SRC_URI = "git://github.com/ImageMagick/ImageMagick.git;branch=main;protocol=https"
Andrew Geissler615f2f12022-07-15 14:00:58 -050015SRCREV = "35b4991eb0939a327f3489988c366e21068b0178"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig update-alternatives
20
21# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
22# if someone needs xml support then fix it first
23EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl"
24
25CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050027PACKAGECONFIG[cxx] = "--with-magick-plus-plus,--without-magick-plus-plus"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz"
29PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
30PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
31PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
32PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033PACKAGECONFIG[rsvg] = "--with-rsvg,--without-rsvg,librsvg"
Brad Bishope42b3e32020-01-15 22:08:42 -050034PACKAGECONFIG[tcmalloc] = "--with-tcmalloc=yes,--with-tcmalloc=no,gperftools"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
36PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
37PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:${PN} += "${libdir}/ImageMagick-${BASE_PV}/config-Q16* \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 ${datadir}/ImageMagick-7"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${PN}-dev += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/*.a"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
Patrick Williams213cb262021-08-07 19:21:33 -050044FILES:${PN}-dbg += "${libdir}/ImageMagick-${BASE_PV}/modules-Q16/*/.debug/*"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045
46BBCLASSEXTEND = "native"
47
48ALTERNATIVE_PRIORITY = "100"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050ALTERNATIVE:${PN} = "animate compare composite conjure convert display \
Andrew Geisslerd688a012020-09-18 13:36:00 -050051 identify import magick-script mogrify montage stream"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050052
53ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im7"
54ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im7"
55ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im7"
56ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im7"
57ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im7"
58ALTERNATIVE_TARGET[display] = "${bindir}/display.im7"
59ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im7"
60ALTERNATIVE_TARGET[import] = "${bindir}/import.im7"
Andrew Geisslerd688a012020-09-18 13:36:00 -050061ALTERNATIVE_TARGET[magick-script] = "${bindir}/magick-script.im7"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050062ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im7"
63ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im7"
64ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im7"
65
Patrick Williams213cb262021-08-07 19:21:33 -050066ALTERNATIVE:${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050067 convert.1 display.1 identify.1 import.1 magick-script.1 mogrify.1 montage.1 stream.1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050068
69ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
70ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im7.1"
71ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
72ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im7.1"
73ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
74ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im7.1"
75ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
76ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im7.1"
77ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
78ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im7.1"
79ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
80ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im7.1"
81ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
82ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im7.1"
83ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
84ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im7.1"
Andrew Geisslerd688a012020-09-18 13:36:00 -050085ALTERNATIVE_LINK_NAME[magick-script.1] = "${mandir}/man1/magick-script.1"
86ALTERNATIVE_TARGET[magick-script.1] = "${mandir}/man1/magick-script.im7.1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
88ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im7.1"
89ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
90ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im7.1"
91ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
92ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im7.1"