blob: b81050b25ab637030fbecb27dce75405d3cecb20 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
7SRC_URI = "git://github.com/michaelrsweet/mxml.git;nobranch=1;protocol=https"
8SRCREV = "fd47c7d115191c8a6bce2c781ffee41e179530f2"
9S = "${WORKDIR}/git"
10
11inherit autotools
12
13PACKAGECONFIG ??= "threads"
14PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
15
16# Package does not support out of tree builds.
17B = "${S}"
18
19# MXML uses autotools but it explicitly states it does not support autoheader.
20EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
21
22do_configure:prepend() {
23 # Respect optimization CFLAGS specified by OE.
24 sed -e 's/-Os -g//' -i ${S}/configure.ac
25
26 # Enable verbose compilation output. This is required for extra QA checks to work.
27 sed -e '/.SILENT:/d' -i ${S}/Makefile.in
28}
29
30do_install() {
31 # Package uses DSTROOT instread of standard DESTDIR to specify install location.
32 oe_runmake install DSTROOT=${D}
33}