blob: be1ef3f790339b7ef262a034753663834b60753c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-py_base_stacktrace.c-include-glib.h.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000013"
14SRCREV = "f8a0dbfe7fcc6e44f03d66ca5c81363aea318380"
15S = "${WORKDIR}/git"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
18
19DEPENDS += " \
20 gdb \
21 gperf-native \
22 json-c \
23 nettle \
24 glib-2.0 \
25"
26
27PACKAGES += "python3-${BPN}"
28FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
29
30PACKAGECONFIG ??= "python3 rpm"
31PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
32PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
33
34do_configure:prepend() {
35 ${S}/gen-version
36}