blob: a7d9263513039c495187477d133f2cfe9dbf1e37 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRCREV = "76fb40d95455f249bd70824ecfcae7a8f0930fa3"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
8
9DEPENDS += "fmt"
10
11S = "${WORKDIR}/git"
12
13BBCLASSEXTEND = "native"
14# no need to build example & tests & benchmarks on pure yocto
15EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
16
17inherit cmake