blob: 3d8a67ba5633852151af7b8167dfb3835abb9a6b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
2HOMEPAGE = "https://github.com/ethereum/eth-abi"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=bf9691ead96f1163622689e47ce3f366"
6
7SRC_URI[sha256sum] = "c3872e3ac1e9ef3f8c6599aaca4ee536d536eefca63a6892ab937f0560edb656"
8
9PYPI_PACKAGE = "eth_abi"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN} += " \
14 python3-eth-typing \
15 python3-eth-utils \
16 python3-parsimonious \
17 python3-setuptools \
18"