blob: d1698f59319b0b0e5723061b0f6420e94dcd5c0f [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3AUTHOR = "Google Cloud Platform"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "ed65ecf9f681832298e29328e1ef0a3676e3732b2e56f41532d45f70a22de0fb"
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19"
20
21RDEPENDS:${PN} += "\
22 ${PYTHON_PN}-aiohttp \
23 ${PYTHON_PN}-cachetools \
24 ${PYTHON_PN}-pyasn1-modules \
25 ${PYTHON_PN}-rsa \
26 ${PYTHON_PN}-six \
27"