blob: 66aefac3d67a64931676968f11776d7b15cc8441 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Seamless operability between C++11 and Python"
2HOMEPAGE = "https://github.com/wjakob/pybind11"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
5
6DEPENDS = "boost"
7
8SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
9 file://0001-Do-not-strip-binaries.patch \
10"
11
12SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
19
20inherit cmake setuptools3 python3native
21
22PIP_INSTALL_DIST_PATH = "${S}/dist"
23PIP_INSTALL_PACKAGE = "pybind11"
24
25do_configure() {
26 cmake_do_configure
27}
28
29do_compile() {
30 setuptools3_do_compile
31 cmake_do_compile
32}
33
34do_install() {
35 setuptools3_do_install
36 cmake_do_install
37}
38
39BBCLASSEXTEND = "native nativesdk"