blob: 40cb22b5e1dbe46d613caca095c6109ee9736df7 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "PyZMQ: Python bindings for ZMQ"
2DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
3HOMEPAGE = "http://zeromq.org/bindings:python"
4LICENSE = "BSD-3-Clause & LGPL-3.0-only"
5LIC_FILES_CHKSUM = "\
6 file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \
7 file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e \
8"
9
10DEPENDS = "python3-packaging-native zeromq"
11
12SRC_URI:append = " \
13 file://club-rpath-out.patch \
14 file://run-ptest \
15"
16SRC_URI[sha256sum] = "2b381aa867ece7d0a82f30a0c7f3d4387b7cf2e0697e33efaa5bed6c5784abcd"
17
18inherit pypi pkgconfig python_setuptools_build_meta ptest
19
20PACKAGES =+ "\
21 ${PN}-test \
22"
23
24FILES:${PN}-test += "\
25 ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
26"
27
28RDEPENDS:${PN} += "\
29 ${PYTHON_PN}-json \
30 ${PYTHON_PN}-multiprocessing \
31"
32
33RDEPENDS:${PN}-ptest += "\
34 ${PN}-test \
35"
36
37do_compile:prepend() {
38 echo [global] > ${S}/setup.cfg
39 echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg
40 echo have_sys_un_h = True >> ${S}/setup.cfg
41 echo skip_check_zmq = True >> ${S}/setup.cfg
42 echo libzmq_extension = False >> ${S}/setup.cfg
43 echo no_libzmq_extension = True >> ${S}/setup.cfg
44}
45
46do_install_ptest() {
47 install -d ${D}${PTEST_PATH}/tests
48 cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
49}