Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 1 | SUMMARY = "Linux encrypted filesystem management tool" |
| 2 | HOMEPAGE = "http://cryptmount.sourceforge.net/" |
| 3 | LIC_FILES_CHKSUM = "file://README;beginline=3;endline=4;md5=673a990de93a2c5531a0f13f1c40725a" |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | |
| 6 | SRC_URI = "https://sourceforge.net/projects/cryptmount/files/${BPN}/${BPN}-5.3/${BPN}-${PV}.tar.gz \ |
| 7 | file://remove_linux_fs.patch \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[sha256sum] = "682953ff5ba497d48d6b13e22ca726c98659abd781bb8596bb299640dd255d9b" |
| 11 | |
| 12 | inherit autotools-brokensep gettext pkgconfig systemd |
| 13 | |
| 14 | EXTRA_OECONF = " --enable-cswap --enable-fsck --enable-argv0switch" |
| 15 | |
| 16 | PACKAGECONFIG ?="intl luks gcrypt nls" |
| 17 | PACKAGECONFIG:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
| 18 | |
| 19 | PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd" |
| 20 | PACKAGECONFIG[intl] = "--with-libintl-prefix, --without-libintl-prefix" |
| 21 | PACKAGECONFIG[gcrypt] = "--with-libgcrypt, --without-libgcrypt, libgcrypt" |
| 22 | PACKAGECONFIG[luks] = "--enable-luks, --disable-luks, cryptsetup" |
| 23 | PACKAGECONFIG[nls] = "--enable-nls, --disable-nls, " |
| 24 | |
| 25 | SYSTEMD_SERVICE:${PN} = "cryptmount.service" |
| 26 | |
| 27 | RDEPENDS:${PN} = "libdevmapper" |