blob: 18e89b1cf2aba9dfd829d2ba4426a6ee3a649038 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# Class for use to convert all CRLF line terminators to LF
8# provided that some projects are being developed/maintained
9# on Windows so they have different line terminators(CRLF) vs
10# on Linux(LF), which can cause annoying patching errors during
11# git push/checkout processes.
12
13do_convert_crlf_to_lf[depends] += "dos2unix-native:do_populate_sysroot"
14
15# Convert CRLF line terminators to LF
16do_convert_crlf_to_lf () {
17 find ${S} -type f -exec dos2unix {} \;
18}
19
20addtask convert_crlf_to_lf after do_unpack before do_patch