blob: 8b7eaacea3faedd6feaf49c0b51f4538755bd71b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# gi-docgen is a new gnome documentation generator, which
8# seems to be a successor to gtk-doc:
9# https://gitlab.gnome.org/GNOME/gi-docgen
10
11# This variable is set to True if api-documentation is in
12# DISTRO_FEATURES, and False otherwise.
13GIDOCGEN_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', 'True', 'False', d)}"
14# When building native recipes, disable gi-docgen, as it is not necessary,
15# pulls in additional dependencies, and makes build times longer
16GIDOCGEN_ENABLED:class-native = "False"
17GIDOCGEN_ENABLED:class-nativesdk = "False"
18
19# meson: default option name to enable/disable gi-docgen. This matches most
20# projects' configuration. In doubts - check meson_options.txt in project's
21# source path.
22GIDOCGEN_MESON_OPTION ?= 'gtk_doc'
23GIDOCGEN_MESON_ENABLE_FLAG ?= 'true'
24GIDOCGEN_MESON_DISABLE_FLAG ?= 'false'
25
26# Auto enable/disable based on GIDOCGEN_ENABLED
27EXTRA_OEMESON:prepend = "-D${GIDOCGEN_MESON_OPTION}=${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '${GIDOCGEN_MESON_ENABLE_FLAG}', '${GIDOCGEN_MESON_DISABLE_FLAG}', d)} "
28
29DEPENDS:append = "${@' gi-docgen-native gi-docgen' if d.getVar('GIDOCGEN_ENABLED') == 'True' else ''}"
30