blob: 7f522a1ed324d21b21460cb3fbc6d2af11a51fe6 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# This variable is set to True if gobject-introspection-data is in
8# DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise.
9#
10# It should be used in recipes to determine whether introspection data should be built,
11# so that qemu use can be avoided when necessary.
12GI_DATA_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'gobject-introspection-data', \
13 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
14
15do_compile:prepend() {
16 # This prevents g-ir-scanner from writing cache data to $HOME
17 export GI_SCANNER_DISABLE_CACHE=1
18}