blob: 094b563b1a46fb050a5ce96ef7bf2006e49b649e [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit kernel-arch
8
9# We do the dependency this way because the output is not preserved
10# in sstate, so we must force do_compile to run (once).
11do_configure[depends] += "make-mod-scripts:do_compile"
12
13export OS = "${TARGET_OS}"
14export CROSS_COMPILE = "${TARGET_PREFIX}"
15
16# This points to the build artefacts from the main kernel build
17# such as .config and System.map
18# Confusingly it is not the module build output (which is ${B}) but
19# we didn't pick the name.
20export KBUILD_OUTPUT = "${STAGING_KERNEL_BUILDDIR}"
21
22export KERNEL_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}"
23KERNEL_OBJECT_SUFFIX = ".ko"
24
25# kernel modules are generally machine specific
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27