blob: 654a002fdb94fa2c454fdf17c1ff4d4700f5401a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit python3-dir
8
9PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
10EXTRANATIVEPATH += "python3-native"
11DEPENDS:append = " python3-native "
12
13# python-config and other scripts are using sysconfig modules
14# which we patch to access these variables
15export STAGING_INCDIR
16export STAGING_LIBDIR
17
18# Packages can use
19# find_package(PythonInterp REQUIRED)
20# find_package(PythonLibs REQUIRED)
21# which ends up using libs/includes from build host
22# Therefore pre-empt that effort
23export PYTHON_LIBRARY="${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so"
24export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
25
26# suppress host user's site-packages dirs.
27export PYTHONNOUSERSITE = "1"
28
29# autoconf macros will use their internal default preference otherwise
30export PYTHON