blob: 21b688ced07d061953a3ba8aab121302accf63b5 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7DEPENDS:append:class-target = " ${PYTHON_PN}-native ${PYTHON_PN}"
8DEPENDS:append:class-nativesdk = " ${PYTHON_PN}-native ${PYTHON_PN}"
9RDEPENDS:${PN}:append:class-target = " ${PYTHON_PN}-core"
10
11export STAGING_INCDIR
12export STAGING_LIBDIR
13
14# LDSHARED is the ld *command* used to create shared library
15export LDSHARED = "${CCLD} -shared"
16# LDXXSHARED is the ld *command* used to create shared library of C++
17# objects
18export LDCXXSHARED = "${CXX} -shared"
19# CCSHARED are the C *flags* used to create objects to go into a shared
20# library (module)
21export CCSHARED = "-fPIC -DPIC"
22# LINKFORSHARED are the flags passed to the $(CC) command that links
23# the python executable
24export LINKFORSHARED = "${SECURITY_CFLAGS} -Xlinker -export-dynamic"
25
26FILES:${PN} += "${libdir}/* ${libdir}/${PYTHON_DIR}/*"
27
28FILES:${PN}-staticdev += "\
29 ${PYTHON_SITEPACKAGES_DIR}/*.a \
30"
31FILES:${PN}-dev += "\
32 ${datadir}/pkgconfig \
33 ${libdir}/pkgconfig \
34 ${PYTHON_SITEPACKAGES_DIR}/*.la \
35"
36inherit python3native python3targetconfig
37