blob: d0bc3ecfac6ddadb87fd3948ad7050dd0c182dbf [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007# Class for setting up /etc in overlayfs
8#
9# In order to have /etc directory in overlayfs a special handling at early boot stage is required
10# The idea is to supply a custom init script that mounts /etc before launching actual init program,
11# because the latter already requires /etc to be mounted
12#
13# The configuration must be machine specific. You should at least set these three variables:
14# OVERLAYFS_ETC_MOUNT_POINT ?= "/data"
15# OVERLAYFS_ETC_FSTYPE ?= "ext4"
16# OVERLAYFS_ETC_DEVICE ?= "/dev/mmcblk0p2"
17#
18# To control more mount options you should consider setting mount options:
19# OVERLAYFS_ETC_MOUNT_OPTIONS ?= "defaults"
20#
21# The class provides two options for /sbin/init generation
22# 1. Default option is to rename original /sbin/init to /sbin/init.orig and place generated init under
23# original name, i.e. /sbin/init. It has an advantage that you won't need to change any kernel
24# parameters in order to make it work, but it poses a restriction that package-management can't
25# be used, becaause updating init manager would remove generated script
26# 2. If you are would like to keep original init as is, you can set
27# OVERLAYFS_ETC_USE_ORIG_INIT_NAME = "0"
28# Then generated init will be named /sbin/preinit and you would need to extend you kernel parameters
29# manually in your bootloader configuration.
30#
31# Regardless which mode you choose, update and migration strategy of configuration files under /etc
32# overlay is out of scope of this class
33
34ROOTFS_POSTPROCESS_COMMAND += '${@bb.utils.contains("IMAGE_FEATURES", "overlayfs-etc", "create_overlayfs_etc_preinit;", "", d)}'
Andrew Geissler9aee5002022-03-30 16:27:02 +000035IMAGE_FEATURES_CONFLICTS_overlayfs-etc = "${@ 'package-management' if bb.utils.to_boolean(d.getVar('OVERLAYFS_ETC_USE_ORIG_INIT_NAME'), True) else ''}"
Andrew Geissler595f6302022-01-24 19:11:47 +000036
37OVERLAYFS_ETC_MOUNT_POINT ??= ""
38OVERLAYFS_ETC_FSTYPE ??= ""
39OVERLAYFS_ETC_DEVICE ??= ""
40OVERLAYFS_ETC_USE_ORIG_INIT_NAME ??= "1"
41OVERLAYFS_ETC_MOUNT_OPTIONS ??= "defaults"
42OVERLAYFS_ETC_INIT_TEMPLATE ??= "${COREBASE}/meta/files/overlayfs-etc-preinit.sh.in"
43
44python create_overlayfs_etc_preinit() {
45 overlayEtcMountPoint = d.getVar("OVERLAYFS_ETC_MOUNT_POINT")
46 overlayEtcFsType = d.getVar("OVERLAYFS_ETC_FSTYPE")
47 overlayEtcDevice = d.getVar("OVERLAYFS_ETC_DEVICE")
48
49 if not overlayEtcMountPoint:
50 bb.fatal("OVERLAYFS_ETC_MOUNT_POINT must be set in your MACHINE configuration")
51 if not overlayEtcDevice:
52 bb.fatal("OVERLAYFS_ETC_DEVICE must be set in your MACHINE configuration")
53 if not overlayEtcFsType:
54 bb.fatal("OVERLAYFS_ETC_FSTYPE should contain a valid file system type on {0}".format(overlayEtcDevice))
55
56 with open(d.getVar("OVERLAYFS_ETC_INIT_TEMPLATE"), "r") as f:
57 PreinitTemplate = f.read()
58
59 useOrigInit = oe.types.boolean(d.getVar('OVERLAYFS_ETC_USE_ORIG_INIT_NAME'))
60 preinitPath = oe.path.join(d.getVar("IMAGE_ROOTFS"), d.getVar("base_sbindir"), "preinit")
61 initBaseName = oe.path.join(d.getVar("base_sbindir"), "init")
62 origInitNameSuffix = ".orig"
63
64 args = {
65 'OVERLAYFS_ETC_MOUNT_POINT': overlayEtcMountPoint,
66 'OVERLAYFS_ETC_MOUNT_OPTIONS': d.getVar('OVERLAYFS_ETC_MOUNT_OPTIONS'),
67 'OVERLAYFS_ETC_FSTYPE': overlayEtcFsType,
68 'OVERLAYFS_ETC_DEVICE': overlayEtcDevice,
69 'SBIN_INIT_NAME': initBaseName + origInitNameSuffix if useOrigInit else initBaseName
70 }
71
72 if useOrigInit:
73 # rename original /sbin/init
74 origInit = oe.path.join(d.getVar("IMAGE_ROOTFS"), initBaseName)
75 bb.debug(1, "rootfs path %s, init path %s, test %s" % (d.getVar('IMAGE_ROOTFS'), origInit, d.getVar("IMAGE_ROOTFS")))
76 bb.utils.rename(origInit, origInit + origInitNameSuffix)
77 preinitPath = origInit
78
79 with open(preinitPath, 'w') as f:
80 f.write(PreinitTemplate.format(**args))
81 os.chmod(preinitPath, 0o755)
82}