blob: e46aeb90cb7384e5d6dfc9b2b89d62bb62d4d003 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Controls the configuration of serial ports"
2DESCRIPTION = "setserial is a program designed to set and/or report the configuration information associated with a serial port"
3HOMEPAGE = "http://setserial.sourceforge.net"
4AUTHOR = "Theodore Ts'o <tytso@mit.edu>"
5SECTION = "console/utils"
6
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008LIC_FILES_CHKSUM = "file://version.h;beginline=1;endline=6;md5=2e7c59cb9e57e356ae81f50f4e4dfd99"
9PR = "r3"
10
11DEPENDS += "groff-native"
12
13inherit autotools-brokensep
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${BPN}-${PV}.tar.gz \
16 file://add_stdlib.patch \
17 file://ldflags.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050018 file://0001-setserial.c-Add-needed-system-headers-for-ioctl-and-.patch \
19 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21SRC_URI[md5sum] = "c4867d72c41564318e0107745eb7a0f2"
22SRC_URI[sha256sum] = "7e4487d320ac31558563424189435d396ddf77953bb23111a17a3d1487b5794a"
23
24do_install() {
25 install -d ${D}${bindir}
26 install -d ${D}${mandir}/man8
27
28 install -m 0755 ${S}/setserial ${D}${bindir}
29 install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8
30}