blob: 746d1bc39c97752127363c89a4a14f280949e8cc [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPL-2.1-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.sha256sum] = "cd2a084c7bb91d78e849fb55d40e472f6d8f6862cddc9f12c39149359ba18268"
13
14PACKAGECONFIG ??= "openssl ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
15
16PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
17PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
18PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
19PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false"
20
21EXTRA_OEMESON = "-Dgnome_proxy=disabled"
22
23GNOMEBASEBUILDCLASS = "meson"
24inherit gnomebase gettext upstream-version-is-even gio-module-cache ptest-gnome
25
26SRC_URI += "file://run-ptest"
27
28FILES:${PN} += "\
29 ${libdir}/gio/modules/libgio*.so \
30 ${datadir}/dbus-1/services/ \
31 ${systemd_user_unitdir} \
32 "
33FILES:${PN}-dev += "${libdir}/gio/modules/libgio*.la"
34FILES:${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
35
36RDEPENDS:${PN}-ptest += "bash"
37
38BBCLASSEXTEND = "native nativesdk"