blob: f3e841246f951abbfaca9b1ccda403f215de2cd9 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Linux control group abstraction library"
2HOMEPAGE = "http://libcg.sourceforge.net/"
3DESCRIPTION = "libcgroup is a library that abstracts the control group file system \
4in Linux. Control groups allow you to limit, account and isolate resource usage \
5(CPU, memory, disk I/O, etc.) of groups of processes."
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4d794c5d710e5b3547a6cc6a6609a641"
9
10inherit autotools pkgconfig
11
12DEPENDS = "bison-native flex-native"
13
14SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v3.0/${BP}.tar.gz \
15 file://0001-api-Use-GNU-strerror_r-when-available.patch \
16"
17
18SRC_URI[sha256sum] = "8d284d896fca1c981b55850e92acd3ad9648a69227c028dda7ae3402af878edd"
19UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/releases/"
20
21DEPENDS:append:libc-musl = " fts "
22EXTRA_OEMAKE:append:libc-musl = " LIBS=-lfts"
23
24PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
25PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
26
27PACKAGES =+ "cgroups-pam-plugin"
28FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
29FILES:${PN}-dev += "${base_libdir}/security/*.la"
30FILES:${PN}-staticdev += "${base_libdir}/security/pam_cgroup.a"
31
32do_install:append() {
33 # Until we ship the test suite, this library isn't useful
34 rm -f ${D}${libdir}/libcgroupfortesting.*
35}