blob: dbac02243c0b05d3aec19d8a738361a5d9c429a8 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=7a19377a02749d8a1281ed608169b0ee"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16 file://0001-Include-time.h-for-time_t.patch \
17 file://0002-config-Include-sys-types.h-for-mode_t-defintion.patch \
18"
19SRC_URI[sha256sum] = "6a746a9bed01585388b68e2d58af2e77741fc8d66bc360b5a0b4c41fc284dafe"
20
21UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
22
23inherit cmake
24
25PATCHTOOL = "patch"
26
27BBCLASSEXTEND = "native nativesdk"
28
29PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
30PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"