blob: 2b8bd132f35bad8d233c2e39566cfebf4b4738f3 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3HOMEPAGE = "https://github.com/rpm-software-management/librepo"
4DESCRIPTION = "${SUMMARY}"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;protocol=https \
9 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
10 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
11 file://0001-metadata_downloader-Include-unistd.h-for-lseek.patch \
12 "
13
14SRCREV = "2bd1041c741c85bc196ca01dcca1eae6099eb742"
15
16S = "${WORKDIR}/git"
17
18DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
19
20inherit cmake setuptools3-base pkgconfig
21
22EXTRA_OECMAKE = " \
23 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
24 -DPYTHON_DESIRED=3 \
25 -DENABLE_TESTS=OFF \
26 -DENABLE_DOCS=OFF \
27 -DWITH_ZCHUNK=OFF \
28"
29
30BBCLASSEXTEND = "native nativesdk"