blob: 1bef20c2e253305027d2f8ac19f3a25f921e459c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "ba3224a4e206e1fbdecf98a4fae4992ef9b24b85ebf7b584bb340156eaf08d89"
10
11inherit setuptools3 pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-packaging python3-docutils python3-requests \
21 python3-imagesize python3-alabaster python3-jinja2 \
22 python3-babel python3-pygments python3-snowballstemmer \
23 python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
24 python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
25 python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
26 "
27
28BBCLASSEXTEND = "native nativesdk"