blob: 9b6446f265f5f903f3362c203dc6e5ef078597ce [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY:${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION:${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY:python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION:python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0-only"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c4eec0c20c6034b9407a09945b48a43f"
26
27SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.17.x;protocol=https \
28 file://environment.d-rpm.sh \
29 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
30 file://0001-Do-not-read-config-files-from-HOME.patch \
31 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
32 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
33 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
34 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0001-perl-disable-auto-reqs.patch \
37 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
38 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
39 file://0001-tools-Add-error.h-for-non-glibc-case.patch \
40 file://0001-docs-do-not-build-manpages-requires-pandoc.patch \
41 file://0001-build-pack.c-do-not-insert-payloadflags-into-.rpm-me.patch \
42 file://0001-configure.ac-add-linux-gnux32-variant-to-triplet-han.patch \
43 "
44
45PE = "1"
46SRCREV = "5bef402da334595ed9302b8bca1acdf5e88bfe11"
47
48S = "${WORKDIR}/git"
49
50DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3"
51DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
52
53inherit autotools gettext pkgconfig python3native
54export PYTHON_ABI
55
56AUTOTOOLS_AUXDIR = "${S}/build-aux"
57
58# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
59EXTRA_AUTORECONF:append = " --exclude=gnu-configize"
60
61# Vendor is detected differently on x86 and aarch64 hosts and can feed into target packages
62EXTRA_OECONF:append = " --enable-python --with-crypto=libgcrypt --with-vendor=pc"
63EXTRA_OECONF:append:libc-musl = " --disable-nls --disable-openmp"
64
65# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
66# --localstatedir prevents rpm from writing its database to native sysroot when building images
67# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
68# plugins both behave badly inside builds.
69EXTRA_OECONF:append:class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
70EXTRA_OECONF:append:class-nativesdk = " --sysconfdir=/etc --disable-plugins"
71
72BBCLASSEXTEND = "native nativesdk"
73
74PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)} sqlite zstd"
75# The inhibit plugin serves no purpose outside of the target
76PACKAGECONFIG:remove:class-native = "inhibit"
77PACKAGECONFIG:remove:class-nativesdk = "inhibit"
78
79PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
80PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
81PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
82PACKAGECONFIG[sqlite] = "--enable-sqlite=yes,--enable-sqlite=no,sqlite3"
83PACKAGECONFIG[ndb] = "--enable-ndb,--disable-ndb"
84PACKAGECONFIG[bdb-ro] = "--enable-bdb-ro,--disable-bdb-ro"
85PACKAGECONFIG[zstd] = "--enable-zstd=yes,--enable-zstd=no,zstd"
86
87ASNEEDED = ""
88
89# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
90# libmagic also has sysroot path contamination, so override it
91
92WRAPPER_TOOLS = " \
93 ${bindir}/rpm \
94 ${bindir}/rpm2archive \
95 ${bindir}/rpm2cpio \
96 ${bindir}/rpmbuild \
97 ${bindir}/rpmdb \
98 ${bindir}/rpmgraph \
99 ${bindir}/rpmkeys \
100 ${bindir}/rpmsign \
101 ${bindir}/rpmspec \
102 ${libdir}/rpm/rpmdeps \
103"
104
105do_configure:prepend() {
106 mkdir -p ${S}/build-aux
107}
108
109do_install:append:class-native() {
110 for tool in ${WRAPPER_TOOLS}; do
111 test -x ${D}$tool && create_wrapper ${D}$tool \
112 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
113 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
114 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
115 RPM_NO_CHROOT_FOR_SCRIPTS=1
116 done
117}
118
119do_install:append:class-nativesdk() {
120 for tool in ${WRAPPER_TOOLS}; do
121 test -x ${D}$tool && create_wrapper ${D}$tool \
122 RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \
123 RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \
124 MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \
125 RPM_NO_CHROOT_FOR_SCRIPTS=1
126 done
127
128 rm -rf ${D}/var
129
130 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
131 install -m 644 ${WORKDIR}/environment.d-rpm.sh ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
132}
133
134# Rpm's make install creates var/tmp which clashes with base-files packaging
135do_install:append:class-target() {
136 rm -rf ${D}/var
137}
138do_install:append:class-nativesdk() {
139 rm -rf ${D}${SDKPATHNATIVE}/var
140}
141
142do_install:append () {
143 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
144 ${D}/${libdir}/rpm/macros
145
146}
147
148FILES:${PN} += "${libdir}/rpm-plugins/*.so \
149 "
150FILES:${PN}:append:class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
151
152FILES:${PN}-dev += "${libdir}/rpm-plugins/*.la \
153 "
154PACKAGE_BEFORE_PN += "${PN}-build ${PN}-sign ${PN}-archive"
155
156RRECOMMENDS:${PN} += "rpm-sign rpm-archive"
157
158FILES:${PN}-build = "\
159 ${bindir}/rpmbuild \
160 ${bindir}/gendiff \
161 ${bindir}/rpmspec \
162 ${libdir}/librpmbuild.so.* \
163 ${libdir}/rpm/brp-* \
164 ${libdir}/rpm/check-* \
165 ${libdir}/rpm/debugedit \
166 ${libdir}/rpm/sepdebugcrcfix \
167 ${libdir}/rpm/find-debuginfo.sh \
168 ${libdir}/rpm/find-lang.sh \
169 ${libdir}/rpm/*provides* \
170 ${libdir}/rpm/*requires* \
171 ${libdir}/rpm/*deps* \
172 ${libdir}/rpm/*.prov \
173 ${libdir}/rpm/*.req \
174 ${libdir}/rpm/config.* \
175 ${libdir}/rpm/mkinstalldirs \
176 ${libdir}/rpm/macros.p* \
177 ${libdir}/rpm/fileattrs/* \
178"
179
180FILES:${PN}-sign = "\
181 ${bindir}/rpmsign \
182 ${libdir}/librpmsign.so.* \
183"
184
185FILES:${PN}-archive = "\
186 ${bindir}/rpm2archive \
187"
188
189PACKAGES += "python3-rpm"
190PROVIDES += "python3-rpm"
191FILES:python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
192
193RDEPENDS:${PN}-build = "bash perl python3-core"
194
195PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
196
197# Do not specify a sysroot when compiling on a target.
198rpm_package_preprocess () {
199 sed -i -e 's:--sysroot[^ ]*::g' \
200 ${PKGD}/${libdir}/rpm/macros
201}
202
203SSTATE_HASHEQUIV_FILEMAP = " \
204 populate_sysroot:*/rpm/macros:${TMPDIR} \
205 populate_sysroot:*/rpm/macros:${COREBASE} \
206 "