blob: d56af7346b5606125b0099ad798690badc562902 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "msmtp is an SMTP client"
2DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
3HOMEPAGE = "https://marlam.de/msmtp/"
4SECTION = "console/network"
5
6LICENSE = "GPL-3.0-only"
7DEPENDS = "zlib gnutls"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11UPSTREAM_CHECK_URI = "https://marlam.de/msmtp/download/"
12
13SRC_URI = "https://marlam.de/${BPN}/releases/${BP}.tar.xz"
14SRC_URI[sha256sum] = "1b04206286a5b82622335e4eb09e17074368b7288e53d134543cbbc6b79ea3e7"
15
16inherit gettext autotools update-alternatives pkgconfig
17
18EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
19
20ALTERNATIVE:${PN} = "sendmail"
21# /usr/lib/sendmial is required by LSB core test
22ALTERNATIVE:${PN}:linuxstdbase = "sendmail usr-lib-sendmail"
23ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
24ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
25ALTERNATIVE_TARGET[usr-lib-sendmail] = "${bindir}/msmtp"
26ALTERNATIVE_LINK_NAME[usr-lib-sendmail] = "/usr/lib/sendmail"
27ALTERNATIVE_PRIORITY = "100"