blob: 370662bbb309d0d2a81c3057bce7b9c4675fa527 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
9 file://0001-core-helper-remove-include-of-sys-mount.h.patch \
10 file://0002-core-shim-remove-include-of-sys-mount.h.patch \
11"
12SRCREV = "346518caffe5302f9a6d36860459c297c6968aaa"
13S = "${WORKDIR}/git"
14
15DEPENDS = "coreutils-native"
16
17PROVIDES = "stress"
18RPROVIDES:${PN} = "stress"
19RREPLACES:${PN} = "stress"
20RCONFLICTS:${PN} = "stress"
21
22inherit bash-completion
23
24do_compile:prepend() {
25 mkdir -p configs
26 touch configs/HAVE_APPARMOR
27}
28
29do_install() {
30 oe_runmake DESTDIR=${D} install
31 ln -s stress-ng ${D}${bindir}/stress
32}