blob: 3bdc70d224f9a39c1b57d4200c066fcf9fc00ce0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Library for sending desktop notifications to a notification daemon"
2DESCRIPTION = "It sends desktop notifications to a notification daemon, as defined \
3in the Desktop Notifications spec. These notifications can be used to inform \
4the user about an event or display some form of information without getting \
5in the user's way."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/libnotify"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/libnotify/issues"
8SECTION = "libs"
9LICENSE = "LGPL-2.1-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "dbus glib-2.0 gdk-pixbuf"
13
14PACKAGECONFIG ?= ""
15PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gtk+3"
16
17GNOMEBASEBUILDCLASS = "meson"
18GTKDOC_MESON_OPTION = "gtk_doc"
19GIR_MESON_ENABLE_FLAG = "enabled"
20GIR_MESON_DISABLE_FLAG = "disabled"
21inherit gnomebase gtk-doc features_check gobject-introspection
22# depends on gtk+3 if tests are enabled
23ANY_OF_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'tests', '${GTK3DISTROFEATURES}', '', d)}"
24
25SRC_URI[archive.sha256sum] = "d033e6d4d6ccbf46a436c31628a4b661b36dca1f5d4174fe0173e274f4e62557"
26
27EXTRA_OEMESON = "-Dman=false"
28
29# there were times, we had two versions of libnotify (oe-core libnotify:0.6.x /
30# meta-gnome libnotify3: 0.7.x)
31PROVIDES += "libnotify3"
32RPROVIDES:${PN} += "libnotify3"
33RCONFLICTS:${PN} += "libnotify3"
34RREPLACES:${PN} += "libnotify3"
35
36# -7381 is specific to the NodeJS bindings
37CVE_CHECK_IGNORE += "CVE-2013-7381"