blob: cb4bb936d71ed6646eb9c4683ff4fbdf3f8f4b04 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Apache Portable Runtime (APR) library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002
3DESCRIPTION = "Create and maintain software libraries that provide a predictable \
4and consistent interface to underlying platform-specific implementations."
5
Brad Bishopc342db32019-05-15 21:57:59 -04006HOMEPAGE = "http://apr.apache.org/"
7SECTION = "libs"
8DEPENDS = "util-linux"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
12 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
17 file://run-ptest \
Brad Bishopc342db32019-05-15 21:57:59 -040018 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
19 file://0003-Makefile.in-configure.in-support-cross-compiling.patch \
20 file://0004-Fix-packet-discards-HTTP-redirect.patch \
21 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
22 file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \
23 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040024 file://libtoolize_check.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026 file://autoconf270.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050027 file://0001-add-AC_CACHE_CHECK-for-strerror_r-return-type.patch \
28 file://0001-configure-Remove-runtime-test-for-mmap-that-can-map-.patch \
Andrew Geissler5199d832021-09-24 16:47:35 -050029 file://CVE-2021-35940.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040030 "
31
32SRC_URI[md5sum] = "7a14a83d664e87599ea25ff4432e48a7"
33SRC_URI[sha256sum] = "e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea"
34
Andrew Geissler82c905d2020-04-13 13:39:40 -050035inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
Brad Bishopc342db32019-05-15 21:57:59 -040036
37OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
38
39# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
40CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
Patrick Williams92b42cb2022-09-03 06:53:57 -050041# Enable largefile
42CACHED_CONFIGUREVARS += "apr_cv_use_lfs64=yes"
43# Additional AC_TRY_RUN tests which will need to be cached for cross compile
44CACHED_CONFIGUREVARS += "apr_cv_epoll=yes epoll_create1=yes apr_cv_sock_cloexec=yes \
45 ac_cv_struct_rlimit=yes \
46 ac_cv_func_sem_open=yes \
47 apr_cv_process_shared_works=yes \
48 apr_cv_mutex_robust_shared=yes \
49 "
Brad Bishopc342db32019-05-15 21:57:59 -040050# Also suppress trying to use sctp.
51#
52CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
53
Patrick Williams92b42cb2022-09-03 06:53:57 -050054# ac_cv_sizeof_struct_iovec is deduced using runtime check which will fail during cross-compile
55CACHED_CONFIGUREVARS += "${@['ac_cv_sizeof_struct_iovec=16','ac_cv_sizeof_struct_iovec=8'][d.getVar('SITEINFO_BITS') != '32']}"
56
Brad Bishopc342db32019-05-15 21:57:59 -040057CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
58
Patrick Williams92b42cb2022-09-03 06:53:57 -050059CACHED_CONFIGUREVARS:append:libc-musl = " ac_cv_strerror_r_rc_int=yes"
Brad Bishopc342db32019-05-15 21:57:59 -040060PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050061PACKAGECONFIG:append:libc-musl = " xsi-strerror"
Brad Bishopc342db32019-05-15 21:57:59 -040062PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050063PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
Patrick Williams92b42cb2022-09-03 06:53:57 -050064PACKAGECONFIG[xsi-strerror] = "ac_cv_strerror_r_rc_int=yes,ac_cv_strerror_r_rc_int=no,"
Brad Bishopc342db32019-05-15 21:57:59 -040065
Patrick Williams213cb262021-08-07 19:21:33 -050066do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040067 # Avoid absolute paths for grep since it causes failures
68 # when using sstate between different hosts with different
69 # install paths for grep.
70 export GREP="grep"
71
72 cd ${S}
Brad Bishop00e122a2019-10-05 11:10:57 -040073 # The "2" means libtool version 2.
74 ./buildconf 2
Brad Bishopc342db32019-05-15 21:57:59 -040075}
76
Andrew Geissler82c905d2020-04-13 13:39:40 -050077MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
78 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
79
Patrick Williams213cb262021-08-07 19:21:33 -050080FILES:${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
Andrew Geissler595f6302022-01-24 19:11:47 +000081RDEPENDS:${PN}-dev += "bash libtool"
Brad Bishopc342db32019-05-15 21:57:59 -040082
Patrick Williams213cb262021-08-07 19:21:33 -050083RDEPENDS:${PN}-ptest += "libgcc"
Brad Bishop393846f2019-05-20 12:24:11 -040084
Brad Bishopc342db32019-05-15 21:57:59 -040085#for some reason, build/libtool.m4 handled by buildconf still be overwritten
86#when autoconf, so handle it again.
Patrick Williams213cb262021-08-07 19:21:33 -050087do_configure:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040088 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
89 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
90}
91
Patrick Williams213cb262021-08-07 19:21:33 -050092do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040093 oe_multilib_header apr.h
94 install -d ${D}${datadir}/apr
95}
96
Patrick Williams213cb262021-08-07 19:21:33 -050097do_install:append:class-target() {
Andrew Geissler595f6302022-01-24 19:11:47 +000098 rm -f ${D}${datadir}/build-1/libtool
99 sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g ${D}${datadir}/build-1/apr_rules.mk
Brad Bishopc342db32019-05-15 21:57:59 -0400100 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
101 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
102 sed -i -e 's,${STAGING_DIR_HOST},,g' \
103 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
104 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
105}
106
107SSTATE_SCAN_FILES += "apr_rules.mk libtool"
108
109SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
110
111apr_sysroot_preprocess () {
112 d=${SYSROOT_DESTDIR}${datadir}/apr
113 install -d $d/
114 cp ${S}/build/apr_rules.mk $d/
115 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
116 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
Andrew Geissler595f6302022-01-24 19:11:47 +0000117 sed -i s,LIBTOOL=.*,LIBTOOL=libtool,g $d/apr_rules.mk
Brad Bishopc342db32019-05-15 21:57:59 -0400118 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
119 cp ${S}/build/mkdir.sh $d/
120 cp ${S}/build/make_exports.awk $d/
121 cp ${S}/build/make_var_export.awk $d/
Andrew Geissler595f6302022-01-24 19:11:47 +0000122 cp ${S}/libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
Brad Bishopc342db32019-05-15 21:57:59 -0400123}
124
125do_compile_ptest() {
126 cd ${S}/test
127 oe_runmake
128}
129
130do_install_ptest() {
131 t=${D}${PTEST_PATH}/test
132 mkdir -p $t/.libs
133 cp -r ${S}/test/data $t/
134 cp -r ${S}/test/.libs/*.so $t/.libs/
135 cp ${S}/test/proc_child $t/
136 cp ${S}/test/readchild $t/
137 cp ${S}/test/sockchild $t/
138 cp ${S}/test/sockperf $t/
139 cp ${S}/test/testall $t/
140 cp ${S}/test/tryread $t/
141}
142
143export CONFIG_SHELL="/bin/bash"