blob: fad92df5075772f8e06b58a3c730e8fa0fafd81f [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "A library for atomic integer operations"
2DESCRIPTION = "Package provides semi-portable access to hardware-provided atomic memory update operations on a number of architectures."
3HOMEPAGE = "https://github.com/ivmai/libatomic_ops/"
4SECTION = "optional"
5PROVIDES += "libatomics-ops"
6LICENSE = "GPL-2.0-only & MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://doc/LICENSING.txt;md5=dfc50c7cea7b66935844587a0f7389e7 \
9 "
10
11SRC_URI = "https://github.com/ivmai/libatomic_ops/releases/download/v${PV}/libatomic_ops-${PV}.tar.gz"
12UPSTREAM_CHECK_URI = "https://github.com/ivmai/libatomic_ops/releases"
13
14SRC_URI[sha256sum] = "390f244d424714735b7050d056567615b3b8f29008a663c262fb548f1802d292"
15
16S = "${WORKDIR}/libatomic_ops-${PV}"
17
18ALLOW_EMPTY:${PN} = "1"
19
20inherit autotools pkgconfig
21
22BBCLASSEXTEND = "native nativesdk"