blob: 043fed367c647c779ff2d2bbe7d3ad1bd35accac [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
10SRC_URI[sha256sum] = "9278907a6f571b391aab9644fd646a5108ed97311ec66f6359cebbedb0a4e3bb"
11
12inherit autotools lib_package pkgconfig gettext
13
14CFLAGS += "-pthread -D_REENTRANT"
15
Patrick Williams92b42cb2022-09-03 06:53:57 -050016EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --enable-largefile"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
18PACKAGECONFIG ?= "curl https"
Patrick Williams92b42cb2022-09-03 06:53:57 -050019
Andrew Geissler595f6302022-01-24 19:11:47 +000020PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
21PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
22
23do_compile:append() {
24 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25}
26
27BBCLASSEXTEND = "native nativesdk"