blob: 6ecf2e21c0674fc0d7e815dc12c8f41ae76b66cf [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Userspace RCU (read-copy-update) library"
2DESCRIPTION = "A userspace RCU (read-copy-update) library. This data \
3synchronization library provides read-side access which scales linearly \
4with the number of cores. "
5HOMEPAGE = "http://lttng.org/urcu"
6BUGTRACKER = "http://lttng.org/project/issues"
7
8LICENSE = "LGPL-2.1-or-later & MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
10 file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
11 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
12
13SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
14
15SRC_URI[sha256sum] = "1213fd9f1b0b74da7de2bb74335b76098db9738fec5d3cdc07c0c524f34fc032"
16
17S = "${WORKDIR}/userspace-rcu-${PV}"
18inherit autotools multilib_header
19
20CPPFLAGS:append:riscv64 = " -pthread -D_REENTRANT"
21
22do_install:append() {
23 oe_multilib_header urcu/config.h
24}