blob: a2a178bab5c53bc3dc81f27ab9b0cd0d31ba0bad [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3HOMEPAGE = "https://github.com/lz4/lz4"
4
5LICENSE = "BSD-2-Clause | GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=5cd5f851b52ec832b10eedb3f01f885a \
7 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://LICENSE;md5=c5cc3cd6f9274b4d32988096df9c3ec3 \
9 "
10
11PE = "1"
12
13SRCREV = "5ff839680134437dbf4678f3d0c7b371d84f4964"
14
15SRC_URI = "git://github.com/lz4/lz4.git;branch=release;protocol=https"
16UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
17
18S = "${WORKDIR}/git"
19
20# Fixed in r118, which is larger than the current version.
21CVE_CHECK_IGNORE += "CVE-2014-4715"
22
23EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' CFLAGS='${CFLAGS}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no"
24
25do_install() {
26 oe_runmake install
27}
28
29BBCLASSEXTEND = "native nativesdk"