blob: dce29a93cdcf199868028e6135d2d7f80d5f22d7 [file] [log] [blame]
Patrick Williams8dd68482022-10-04 07:57:18 -05001SUMMARY = "External system Cortex-M3 Firmware"
2DESCRIPTION = "Firmware to be loaded and run in External System Harness in\
3 support to the main application CPU."
4HOMEPAGE = "https://git.linaro.org/landing-teams/working/arm/external-system.git"
5DEPENDS = "gcc-arm-none-eabi-native"
6INHIBIT_DEFAULT_DEPS="1"
7LICENSE = "BSD-3-Clause & Apache-2.0"
8LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \
9 file://cmsis/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Andrew Geissler9347dd42023-03-03 12:38:41 -060011SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master \
12 file://race.patch"
Patrick Williams8dd68482022-10-04 07:57:18 -050013SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080"
14PV .= "+git${SRCPV}"
15
16COMPATIBLE_MACHINE = "(corstone1000)"
17
18# PRODUCT is passed to the Makefile to specify the platform to be used.
19PRODUCT = "corstone-1000"
20
21S = "${WORKDIR}/git"
22B = "${WORKDIR}/build"
23
24LDFLAGS[unexport] = "1"
25
26do_compile() {
27 oe_runmake -C ${S} V=y \
28 BUILD_PATH=${B} \
29 PRODUCT=${PRODUCT} \
30 CROSS_COMPILE=arm-none-eabi- \
31 all
32}
33
34do_compile[cleandirs] = "${B}"
35
36do_install() {
37 install -D -p -m 0644 ${B}/product/${PRODUCT}/firmware/release/bin/firmware.bin ${D}/firmware/es_flashfw.bin
38}
39
40FILES:${PN} = "/firmware"
41SYSROOT_DIRS += "/firmware"
42
43inherit deploy
44
45do_deploy() {
46 cp -rf ${D}/firmware/* ${DEPLOYDIR}/
47}
48addtask deploy after do_install