blob: 6ef4f6ce095251388d339e6176e5badb2d2f119f [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001require recipes-bsp/uefi/edk2-firmware_202205.bb
2PROVIDES:remove = "virtual/bootloader"
3
4LICENSE += "& Apache-2.0"
5LIC_FILES_CHKSUM += "file://ShellPkg/Application/sbsa-acs/LICENSE.md;md5=2a944942e1496af1886903d274dedb13"
6
7SRC_URI += "git://github.com/ARM-software/sbsa-acs;destsuffix=edk2/ShellPkg/Application/sbsa-acs;protocol=https;branch=master;name=acs \
8 git://github.com/tianocore/edk2-libc;destsuffix=edk2/edk2-libc;protocol=https;branch=master;name=libc \
9 file://shell.patch \
10 file://use_bfd_linker.patch \
Andrew Geissler9347dd42023-03-03 12:38:41 -060011 file://0001-Fix-function-protype-mismatches.patch;patchdir=ShellPkg/Application/sbsa-acs \
12 file://0001-Fix-for-issue-245.patch;patchdir=ShellPkg/Application/sbsa-acs \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040013 "
14
Andrew Geissler9347dd42023-03-03 12:38:41 -060015
16SRCREV_acs = "7d7a3fe81ad7e6f05143ba17db50107f1ab6c9cd"
17SRCREV_libc = "a806ea1062c254bd6e09db7d0f7beb4d14bc3ed0"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040018
19# GCC12 trips on it
20#see https://src.fedoraproject.org/rpms/edk2/blob/rawhide/f/0032-Basetools-turn-off-gcc12-warning.patch
21BUILD_CFLAGS += "-Wno-error=stringop-overflow"
22
23COMPATIBLE_HOST = "aarch64.*-linux"
24COMPATIBLE_MACHINE = ""
25PACKAGE_ARCH = "${TUNE_PKGARCH}"
26
27EDK2_PLATFORM = "Shell"
28EDK2_PLATFORM_DSC = "ShellPkg/ShellPkg.dsc"
29EDK2_EXTRA_BUILD = "--module ShellPkg/Application/sbsa-acs/uefi_app/SbsaAvs.inf"
30
31PACKAGES_PATH .= ":${S}/edk2-libc"
32
33do_install() {
34 install -d ${D}/firmware
35 install ${B}/Build/${EDK2_PLATFORM}/${EDK2_BUILD_MODE}_${EDK_COMPILER}/*/Sbsa.efi ${D}/firmware/
36}