blob: 813ff74adf9b96f739e2ff291f83a79eda319abc [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A thin layer of graphic data types"
2HOMEPAGE = "http://ebassi.github.io/graphene/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gobject-introspection gtk-doc
9
10SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
11
12# gtk4 & mutter 41.0 requires graphene build with introspection
13PACKAGECONFIG ?= "introspection"
14PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
15
16GTKDOC_MESON_OPTION = "gtk_doc"
17
18EXTRA_OEMESON = "-Dinstalled_tests=false"
19
20FILES:${PN} += "${libdir}/graphene-1.0"
21
22BBCLASSEXTEND = "native nativesdk"