blob: 6f6f85d78a3f907501d7589b51558ea00f43e962 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
5
6SRC_URI[sha256sum] = "49d43402c6e3013ad0978602bf6bf5328535c48d192304b91b97a3c6790b1562"
7
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest setuptools3
13
14RDEPENDS:${PN} = "\
15 ${PYTHON_PN}-multidict \
16 ${PYTHON_PN}-idna \
17 ${PYTHON_PN}-io \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}